Results 1 to 4 of 4

Thread: Service and warning light on start-up

  1. #1

    Service and warning light on start-up

    Hi all.

    I currently have around 14500mi on my GT and noticed when I start it now the hazard symbol now appears and it says service next to the number of miles in the odometer.

    I had it serviced at 12K mi and also had the tension recall done at 13.5K miles.

    Should this be cause for major concern. I also here ticking now from the engine, its very faint and could be the valves but figured I would ask.

  2. #2
    Senior Member
    Join Date
    May 2014
    Location
    wilmington vermont
    Posts
    257
    The ticking is common from the engine, maybe the tech forgot to reset the service reminder, I had them set the reminder far ahead I figured I could remember when I should have service done. The reminder would just annoy me.
    AKA Bill Steele

  3. #3
    Senior Member bicyclenut's Avatar
    Join Date
    Jun 2016
    Location
    Chicago Suburbs, IL
    Posts
    100
    As Wsteele said, tech probably forgot to reset. My techs at our auto shop sometimes do this and I know it annoys customers and I am on them about this when they do anytime. I think sometimes when the light is not on to remind them to do so they forget it and then the customer drives another 100 miles and reaches the maintenance point and it goes on.

    You can reset it with a GS-911 tool but a bit pricey to get if you just get it for that purpose. It seems that unfortunately there is no shortcut or user method of resetting. On some cars you can just hold the odo reset for x number of seconds when turning on the key or press the accelerator to the floor with key on for so long and will reset, BMW doesn't seem to do this with their cars or motorcycles, you need special tool to do so.

    I'd say my engine can be a bit noisy so unless the tick is severe or the oil level is low, it is probably just the normal sound.

    QUOTE=Akkis;16212]Hi all.

    I currently have around 14500mi on my GT and noticed when I start it now the hazard symbol now appears and it says service next to the number of miles in the odometer.

    I had it serviced at 12K mi and also had the tension recall done at 13.5K miles.

    Should this be cause for major concern. I also here ticking now from the engine, its very faint and could be the valves but figured I would ask.[/QUOTE]
    2014 C650GT Quartz Blue Metallic

  4. #4
    I have the GS911 OBD diagnostic tool and set the reminder mileage to whatever I want it to be. As for ticking, that's always been one complaint I've had with my GT since new, quite a bit of mechanical noise at idle. No change in the noise when I had the timing chain tensioner recall done either.
    2013 C650GT 1994 K1100LT

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •