Results 1 to 4 of 4

Thread: Oil sensor warning lights

  1. #1
    Junior Member
    Join Date
    May 2017
    Location
    United States
    Posts
    1

    Oil sensor warning lights

    I have about 100 miles on my new 2016 C 650 Sport and it has been back to the dealer twice for the oil warning lights coming on and staying on. The dealer admits that this is a problem that BMW has had for some time with the sensor. VERY long story short but both times I picked it up from service the Service Manager has waved off the need to me to receive a repair order invoice for the service. The first time this happened I went to my salesman and insisted on the documentation. He got it promptly. We are now in the midst of the second time the service manager is trying to tell me that no documentation is necessary though he told me on the phone that service had made some corrections. At the least it seems to me this person is sloppy and at the worst it seems he or the dealer may be trying to hide something from me. I know the absolute importance of documentation in terms of my warranty and just general common sense. This is not what I expected when I bought from BMW. Am I missing something here?

  2. #2
    Junior Member Paul Meudt's Avatar
    Join Date
    Aug 2016
    Location
    Monroe, WI
    Posts
    10
    Hey Chickchandler, See this thread on this problem.
    False Oil Check warning is intentional...

  3. #3
    Member
    Join Date
    Dec 2013
    Location
    Philippines
    Posts
    72
    Yesterday, while waiting for the light to turn green and on a slight upslope, the oil warning light came on. When I got the bike moving, the warning light remained on for awhile. Disappeared after about 50 meters. Got home safely.

    Next day, following the procedure for filling oil, I checked and there was sufficient oil per the dipstick. Almost near the max. Just disconcerting when that oil light goes on.

  4. #4
    Junior Member
    Join Date
    Apr 2018
    Location
    Kansas City
    Posts
    12
    When I bought my demo 2016 C650 sport with about 400 miles, the light would come on (yellow triangle / chk oil ). I was told that the problem should go away after the break-in service was done. Well, it didn't. The dealership then replaced the level sensor and for the last 200 miles all is well.

    With that being said, I find it interesting that after replacing the level sensor they asked me if it would be ok if they didn't give me a service ticket.... I was told I could always get one printed out should I want it.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •