Results 1 to 3 of 3

Thread: Ignition switch problem with C650

  1. #1
    Junior Member
    Join Date
    Oct 2018
    Location
    Hanoi, Vietnam
    Posts
    1

    Ignition switch problem with C650

    Hi there, My name is Tim and just joined this very interesting forum. I have a problem that I hope someone can help me with. I purchased my C 650 new about 4 years ago in Germany and have been very happy with it. But about 6 months ago the motor just died while I was riding in Hanoi Vietnam where I live. There isn't a BMW motorbike dealership in Hanoi so I took my bike to a shop that maintains big foreign bikes and has the computer and software gear to check things out. The diagnoses was that the ignition switch had a problem. We sent to Germany for replacement parts, installed them but no success. I would like to ask if anyone has had this problem and what did they do about it. And any other advise would be greatly appreciated. Many thanks in advance. Tim

  2. #2
    Junior Member
    Join Date
    Jul 2014
    Location
    Tulsa, Oklahoma
    Posts
    27
    Have you checked the side stand kill switch? There have been instances where they were loose.

  3. #3
    Junior Member
    Join Date
    Dec 2014
    Location
    Seattle, WA
    Posts
    25
    Maybe the computer was referring to the security ring antenna?
    Click image for larger version. 

Name:	ring antenna.JPG 
Views:	9 
Size:	63.0 KB 
ID:	2279

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •